Vous n'êtes pas identifié(e).

#1 2016-04-09 10:56:03

B33
Membre
Inscription : 2016-04-09
Messages : 11

Tests Mails : OK - Mails d'alertes : ...... KO ??

Bonjour et bravo pour cette application dont l'interface est épurée et efficace.
Je rencontre cependant un pb.
Les mails tests sont nickels et instantanés.
Les mails d'alerte n'ont fonctionné qu'une fois... (mais bien ;-)

Les logs :
2016-04-08T19:48:35+02:00 INFO Vérification des alertes.
2016-04-08T19:48:35+02:00 INFO Contrôle des alertes.
2016-04-08T19:48:36+02:00 INFO User: admin
2016-04-08T19:48:36+02:00 INFO 1 alerte trouvée
2016-04-08T19:48:36+02:00 INFO Contrôle de l'alerte http://www.leboncoin.fr/    [.....................]
2016-04-08T19:48:38+02:00 INFO 5 annonces trouvées
2016-04-09T11:25:49+02:00 INFO Vérification des alertes.
2016-04-09T11:25:49+02:00 INFO Contrôle des alertes.
2016-04-09T11:25:50+02:00 INFO User: admin
2016-04-09T11:25:50+02:00 INFO 1 alerte trouvée
2016-04-09T11:25:50+02:00 INFO Contrôle de l'alerte http://www.leboncoin.fr/    [.....................]
2016-04-09T11:25:51+02:00 INFO 2 annonces trouvées

J'ai essayé sans proxy et désormais avec un proxy.
Le résultat est ok :
utilisation d'un proxy pour la connexion.
Connexion à Free.fr : réussi
Connexion à Leboncoin : réussi

Lorsque je fais un test avec le \check.php, c'est un peu long (bon signe selon moi), mais .... rien.

J'ai cherché sur le forum.
J'ai vu qu'il était question éventuellement d'un fichier "lock".
Je ne l'ai pas trouvé.

Help !

Merci
PS : Est-ce normal que le password figure dans les paramètres du proxy (config.ini) ?

Hors ligne

#2 2016-04-09 16:28:54

Blount
Administrator
Inscription : 2010-11-16
Messages : 687

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Pour le mot de passe dans config.ini, c'est le mot de passe du proxy, pas du compte.

As-tu vérifié tes spams ? Au niveau du serveur, si tu y as accès, il faudrait voir ce qu'il y a dans les logs d'envoi de mail (sur GNU/Linux : /var/log/mail.log par exemple).


Piost - Solution d'hébergement pour Cheky avec installation automatique.
https://www.piost.net

Hors ligne

#3 2016-04-09 16:40:00

B33
Membre
Inscription : 2016-04-09
Messages : 11

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Merci pour ton aide.
Je n'ai malheureusement pas accès aux traces.
Mais le mail d'alerte part bien ... donc curieux.
Une autre idée ?

pour le mot de passe du config.ini. Je n'en définit pas et cela met celui du compte..

Heu ... par contre au noveau des logs j'ai désormais .... :
2016-04-09T18:10:12+02:00 INFO 35 annonces trouvées
2016-04-09T18:10:12+02:00 WARN Impossible d'instancier la fonction mail.

Pas bon signe ?

Dernière modification par B33 (2016-04-09 17:34:08)

Hors ligne

#4 2016-04-09 19:25:48

Blount
Administrator
Inscription : 2010-11-16
Messages : 687

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Arf pour le mot de passe, ça doit venir de l'autocompletion du navigateur.
Va dans l'onglet Proxy, tu vides tous les champs et tu enregistres.

Pour le message "Impossible d'instancier la fonction mail", comment as-tu configurer les mails ? (onglet Mail dans admin)


Piost - Solution d'hébergement pour Cheky avec installation automatique.
https://www.piost.net

Hors ligne

#5 2016-04-10 18:34:06

B33
Membre
Inscription : 2016-04-09
Messages : 11

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Oui, bien vu !
Effectivement c'est Chrome qui renvoie le user et le mot de passe dans les champs du proxy.
Et aussi dans user et pwd du SMTP !!
Donc, ok, j'oublie Chrome et bascule sur Firefox, car cela enregistrait le user/pwd dans le .ini (au niveau du proxy) et le transmettait donc à ce proxy.....

MAIS, cela ne change rien, malheureusement.
=> Aucune réception de mails (sauf celui de test).... sad

Et j'ai toujours "Impossible d'instancier la fonction mail".... ??
Et pourtant le mail de test part...

Le paramétrage des mails est simple puisque je ne renseigne rien à part le mail sortant pour le test (qui marche bien d'ailleurs).
J'en ai essayé plusieurs (gmail, free), mais ... pas mieux.

J'ai essayé AVEC et SANS proxy.
Idem pour les 2 cas.

Et pourtant :
2016-04-10T19:22:55+02:00 INFO Vérification des alertes.
2016-04-10T19:22:55+02:00 INFO Contrôle des alertes.
2016-04-10T19:22:56+02:00 INFO User: admin
2016-04-10T19:22:56+02:00 INFO 3 alertes trouvées
2016-04-10T19:22:56+02:00 INFO Contrôle de l'alerte https://www.leboncoin.fr/     [.....................]
2016-04-10T19:22:57+02:00 INFO Contrôle de l'alerte https://www.leboncoin.fr/     [.....................]
2016-04-10T19:22:59+02:00 INFO Contrôle de l'alerte https://www.leboncoin.fr/     [.....................]
2016-04-10T19:23:00+02:00 INFO 35 annonces trouvées
=>>>>>>>>                2016-04-10T19:23:01+02:00 WARN Impossible d'instancier la fonction mail.            <<<<<<<<<<<====

Je ne pense pas que ce soit du spam détecté par l'hébergeur, auquel cas il bloquerait aussi les mails tests ??
Je me demande dans quelle mesure l'hébergeur (online.net) ne pourrait pas "désinstancier" la fonction mail s'il détecte qu'il y a trop de mails à envoyer d'un coup ???
Mais il devrait au moins envoyer le 1er ? (et bloquer les suivants ... trop rapprochés) ?

Peut-être que je devrais passer par un serveur smtp ?

Encore un peu d'aide possible si je n'abuse pas trop ?

Merci d'avance
Bruno
PS : suggestion : dans les logs, mettre un trait séparateur pour bien distinguer chaque pavé de traitement.

Hors ligne

#6 2016-04-10 18:49:20

B33
Membre
Inscription : 2016-04-09
Messages : 11

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Pour faire avancer le schmilblic (et peut-être aider d'autres personnes dans le même cas), j'ai fait un test avec le serveur SMTP de free.

MAIS .... cela détecte l'envoi de SPAM ... : (message reçu à mon email free pour préciser que l'envoi n'a pas été effectué) :

Final-Recipient: rfc822;       ..... [xxxxxxxxx@free.fr]
Original-Recipient: rfc822;       ..... [xxxxxxxxx@free.fr]
Action: failed
Status: 5.0.0
Remote-MTA: dns; mx1.free.fr
Diagnostic-Code: smtp; 550 spam detected                       <<<<-----

Donc certainement que mon hébergeur faisait pareil.
Donc que faire ?
Quelqu'un connait un serveur SMTP qui accepte de multiples envois ?

Hors ligne

#7 2016-04-13 08:20:50

Blount
Administrator
Inscription : 2010-11-16
Messages : 687

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Essaie le SMTP de Gmail (tu crée un compte rapido si tu n'en a pas).


Piost - Solution d'hébergement pour Cheky avec installation automatique.
https://www.piost.net

Hors ligne

#8 2016-04-13 12:59:39

zebess
Membre
Inscription : 2012-05-29
Messages : 37

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Chez free il faut mettre en smtp: smtp.free.fr  avec le port 465
login: l'adresse email, et le mot de passe
et mettre en ssl sur la sécurité de la connexion.

Hors ligne

#9 2016-04-17 12:42:51

B33
Membre
Inscription : 2016-04-09
Messages : 11

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Bonjour et merci à Blount et Zebess pour votre aide.

Bien malheureusement, je ne trouve pas de solution.
Je serais curieux de savoir si certains arrivent bien à avoir une solution qui fonctionne.
En effet, j'ai fait plusieurs tests :

=> Que ce soit avec SMTP FREE ou GMAIL, et à destination de mails de types FREE, YAHOO et GMAIL.
Soit je ne reçois jamais le mail (et pas dans les spams), soit je peux voir le message suivant (renvoyé à l'expéditeur) :
Delivery to the following recipient failed permanently:

xxxxxxxxxfree.fr

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the server for the recipient domain free.fr by mx1.free.fr. [xxx.yyy.zzz.aaa].

The error that the other server returned was:
550 spam detected
Je précise que j'utilise un proxy
Je précise aussi qu'un envoi avec SMTP Gmail n'arrive jamais sur une adresse Gmail (ET n'apparaît pas dans les spams).
Curieusement Gmail m'informe quand le mail expédié a été détecté comme Spam, par exemple par Free (alors que pourtant cet BAL free reçoit pas mal de Spam régulièrement....)

Donc, comment faire ???
Est-ce que quelqu'un a une solution qui fonctionne ?

Blount, le fait de passer par ta solution piot, ne devrait pas changer la donne, ou au contraire ?

Merci pour l'aide de toute contribution, car je trouve cela vraiment dommage de ne pas pouvoir utiliser cette applicatif extrêment bien fait et utile, à cause de problèmes de cette sorte.
Bruno

PS : suggestion pour Blount : dans les logs, mettre un trait séparateur car à moins de regarder précisément l'heure, il est difficile de bien distinguer chaque pavé de traitement.

Hors ligne

#10 2016-04-19 21:52:11

Blount
Administrator
Inscription : 2010-11-16
Messages : 687

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Tu as accès à la config de PHP ?
Si oui, regarde si le safe_mode est actif. Il pourrait être la cause du message : Impossible d'instancier la fonction mail


Piost - Solution d'hébergement pour Cheky avec installation automatique.
https://www.piost.net

Hors ligne

#11 2016-04-30 19:04:09

B33
Membre
Inscription : 2016-04-09
Messages : 11

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Je réponds un peu tardivement, mais le safe_mode est ok.
Désormais j'ai des ... :
2016-04-30T19:37:26+02:00 INFO [Pid 5] USER : admin - ALERT ID : b92ff3133ce01483aeda1b7d06fb94b80f8a8ddc -> URL : https://www.leboncoin.fr/....

Galère... galère ...

Hors ligne

#12 2016-04-30 22:26:40

Blount
Administrator
Inscription : 2010-11-16
Messages : 687

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Bin ca c'est normal, tu n'as rien d'autre ?
Quand tu dis que le "safe_mode est ok", tu veux dire qu'il est actif ? Parce que l'erreur viendrait du fait qu'il soir actif, il faudrait donc le désactiver.


Piost - Solution d'hébergement pour Cheky avec installation automatique.
https://www.piost.net

Hors ligne

#13 2016-05-01 14:30:42

B33
Membre
Inscription : 2016-04-09
Messages : 11

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Non, le safe_mode est bien "Off"
Les ALERT ID sont normaux ?
A quoi ça sert ?
Je vais creuser encore la question des mails, car apparemment, cela semble fonctionner en SMTP gmail sur Adresse Gmail.
A suivre...

Hors ligne

#14 2016-05-03 13:17:57

B33
Membre
Inscription : 2016-04-09
Messages : 11

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Merci Blount pour ton aide précieuse.

Après analyse, cela fonctionne désormais, mais, il semblerait, uniquement à partir du moment où il n'y aurait pas trop d'éléments ramenés dans le mail ??

Ainsi dans cet exemple, cela n'a fonctionné que lorsqu'il y a eu 2 annonces (et jamais lorsqu'il y en avait 35) :
2016-04-30T19:39:04+02:00 INFO [Pid ] USER : admin
2016-04-30T19:39:04+02:00 INFO [Pid ] USER : admin -> 1 alerte trouvée
2016-04-30T19:39:04+02:00 INFO [Pid ] USER : admin - ALERT ID : e1caf82466824c72562e2095cbaafd2449d3cdb7 -> URL : https://www.leboncoin.fr/[...]
2016-04-30T19:39:04+02:00 INFO [Pid ] USER : admin - ALERT ID : e1caf82466824c72562e2095cbaafd2449d3cdb7 -> 35 annonces trouvées
2016-05-03T09:45:06+02:00 INFO [Pid ] Vérification des alertes.
2016-05-03T09:45:06+02:00 INFO [Pid ] USER : admin
2016-05-03T09:45:07+02:00 INFO [Pid ] USER : admin -> 1 alerte trouvée
2016-05-03T09:45:07+02:00 INFO [Pid ] USER : admin - ALERT ID : e1caf82466824c72562e2095cbaafd2449d3cdb7 -> URL : https://www.leboncoin.fr/[...]
2016-05-03T09:45:07+02:00 INFO [Pid ] USER : admin - ALERT ID : e1caf82466824c72562e2095cbaafd2449d3cdb7 -> 2 annonces trouvées
2016-05-03T10:00:16+02:00 INFO [Pid ] Vérification des alertes.
2016-05-03T10:00:16+02:00 INFO [Pid ] USER : admin
2016-05-03T10:00:16+02:00 INFO [Pid ] USER : admin -> 2 alertes trouvées
2016-05-03T10:00:16+02:00 INFO [Pid ] USER : admin - ALERT ID : e1caf82466824c72562e2095cbaafd2449d3cdb7 -> URL : https://www.leboncoin.fr/[...]
2016-05-03T10:00:17+02:00 INFO [Pid ] USER : admin - ALERT ID : 0f3ddff65e5ff46661a957a7c1427c5813a0d591 -> URL : https://www.leboncoin.fr/[...]
2016-05-03T10:00:17+02:00 INFO [Pid ] USER : admin - ALERT ID : 0f3ddff65e5ff46661a957a7c1427c5813a0d591 -> 35 annonces trouvées

La cause ?
Détection de spam en amont ?
Texte du mail trop volumineux pour la fonction mail de php qui serait bridée ?
Un bug ? (je pense que d'autres personnes l'aurait constaté ;-)
Si quelqu'un a une idée ?

Hors ligne

#15 2018-09-04 11:57:24

Oopsmej
Membre
Inscription : 2018-09-04
Messages : 1

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Same problème.
Safe mode off, aucuns proxy.

Un tip pour m'aider à fix ce prob?

Hors ligne

#16 2018-09-04 12:30:37

jeremy
Membre
Inscription : 2018-09-04
Messages : 4

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Pour ma part, j'ai aujourd'hui des erreurs :

"Une erreur a été rencontrée sur l'alerte :
L'adresse de recherche a généré une erreur 403."

Mais l'url fonctionne... ça sent presque le blocage par leboncoin? :s

Hors ligne

#17 2018-09-04 16:41:04

Blount
Administrator
Inscription : 2010-11-16
Messages : 687

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Oopsmej a écrit :

Same problème.
Safe mode off, aucuns proxy.

Un tip pour m'aider à fix ce prob?

Je n'ai pas trop d'idée, il n'y a rien d'autre dans les logs ?


jeremy a écrit :

Pour ma part, j'ai aujourd'hui des erreurs :

"Une erreur a été rencontrée sur l'alerte :
L'adresse de recherche a généré une erreur 403."

Mais l'url fonctionne... ça sent presque le blocage par leboncoin? :s

Il y a un sujet ouvert avec le titre "Erreur 403" wink
Je pense que tu n'as pas la dernière version de Cheky.


Piost - Solution d'hébergement pour Cheky avec installation automatique.
https://www.piost.net

Hors ligne

#18 2018-09-04 19:02:18

jeremy
Membre
Inscription : 2018-09-04
Messages : 4

Re : Tests Mails : OK - Mails d'alertes : ...... KO ??

Oups, merci !

Hors ligne

Pied de page des forums