Vous n'êtes pas identifié(e).

#1 2017-09-20 10:37:04

roland
Membre
Inscription : 2017-07-16
Messages : 3

Mise à jour 3.5 -> 3.7 impossible

Bonjour.

Par l'admin il m'est impossible de faire la mise à jour :
message : Une vérification de nouvelle annonce est en cours, veuillez attendre la fin de celle-ci pour mettre à jour.

Comment forcer la MAJ manuelle ?

J'ai essayé la méthode 'bruptale' par transfert FTP de la nouvelle version.
Mais au login je suis redirigé sur l'url http://***/?mod=admin&a=upgrade et impossible d'en changer.
Je suis donc revenu (par nouveau transfert FTP à la 3.5)

Merci d'avance.

Dernière modification par roland (2017-09-20 10:37:22)

Hors ligne

#2 2017-09-20 10:41:23

Blount
Administrator
Inscription : 2010-11-16
Messages : 683

Re : Mise à jour 3.5 -> 3.7 impossible

Bonjour,

Le message indique qu'une tâche CRON est en cours pour le contrôle des alertes.
Afin d'éviter des problèmes, j'empêche la mise à jour automatique si un contrôle d'alerte est en cours.

Je te suggère donc de désactiver temporairement ta tâche automatique et tu attends que celle en cours se termine (si c'est le cas).
Ensuite, tu pourras faire la mise à jour.
Tu n'auras plus qu'à remettre en route ta tâche.

Tu exécutes la tâche CRON tous les combien de temps ?


Piost - Solution d'hébergement pour Cheky avec installation automatique.
https://www.piost.net

Hors ligne

#3 2017-09-20 10:55:17

roland
Membre
Inscription : 2017-07-16
Messages : 3

Re : Mise à jour 3.5 -> 3.7 impossible

Merci pour ta réactivité.

La tache CRON est lancé toutes les 5mn.
Je l'ai désactivé, mais j'ai toujours le même message : Une vérification de nouvelle annonce est en cours, veuillez attendre la fin de celle-ci pour mettre à jour.

Je constate qu'en fait cette install ne fonctionnait plus depuis sa mise à jour en 3.5.
J'en ai fait une autre sur un autre serveur où je n'ai pas eu de problème de MAJ 3.5 -> 3.7.

Mais j'aurai bien voulu récupérer mes alertes ou réparer cette install qui est bloquée.

PS : merci d'avoir 'nettoyé' mon url, j'avais zappé.

Hors ligne

#4 2017-09-21 08:45:13

Blount
Administrator
Inscription : 2010-11-16
Messages : 683

Re : Mise à jour 3.5 -> 3.7 impossible

Je vais sauver ton installation.
Supprime le fichier ".lock" dans le répertoire "var" de Cheky. Ca va débloquer la mise à jour et faire fonctionner à nouveau tes alertes.
C'est ce fichier qui est utilisé pour détecter une tâche en cours. Ca permet d'éviter d'avoir plusieurs tâches exécutées simultanément dans le cas où la première mettrait du temps à se terminer.
Hélas, il arrive que ce fichier reste en place lors d'un plantage. Ce risque est fortement diminué en utilisant PHP 7.


Piost - Solution d'hébergement pour Cheky avec installation automatique.
https://www.piost.net

Hors ligne

#5 2017-09-21 09:13:38

roland
Membre
Inscription : 2017-07-16
Messages : 3

Re : Mise à jour 3.5 -> 3.7 impossible

Merci beaucoup.

En supprimant .lock, ca été tout seul, la mise à jour n'a pas pris 1 seconde sur l'install "bloquée".

Je suis effectivement en train de passer à php 7 avec la dernière version de Debian 9 qui vient de sortir il y a tout juste 3 mois.
Mais cela ne se fait pas tout seul...

Hors ligne

Pied de page des forums