Vous n'êtes pas identifié(e).

#1 2017-12-08 14:36:33

noz
Membre
Inscription : 2017-07-18
Messages : 6

Cheky en erreur depuis màj système

Bonjour,

Un petit soucis depuis ce matin, lors de l'accès à la page de cheky, ou l’exécution du cron, j'ai en retour un message "Un problème est survenu lors de l'exécution du programme."

Je me suis rendu compte que ce matin j'ai fait un apt update, et installé quelques applis:

2017-12-08 08:14:06 install libassuan0:amd64 <aucune> 2.4.2-2                                                                     
2017-12-08 08:14:07 install pinentry-curses:amd64 <aucune> 0.9.7-3                                                               
2017-12-08 08:14:09 install libnpth0:amd64 <aucune> 1.2-3                                                                         
2017-12-08 08:14:10 install gnupg-agent:amd64 <aucune> 2.1.11-6ubuntu2                                                           
2017-12-08 08:14:11 install libksba8:amd64 <aucune> 1.3.3-1ubuntu0.16.04.1                                                       
2017-12-08 08:14:12 install gnupg2:amd64 <aucune> 2.1.11-6ubuntu2                                                                 
2017-12-08 08:14:14 install dirmngr:amd64 <aucune> 2.1.11-6ubuntu2                                                               
2017-12-08 08:14:15 install libgpgme11:amd64 <aucune> 1.6.0-1                                                                     
2017-12-08 08:14:15 install libtokyocabinet9:amd64 <aucune> 1.4.48-10                                                             
2017-12-08 08:14:16 install mutt:amd64 <aucune> 1.5.24-1build1                                                                   
2017-12-08 08:52:40 install apt-transport-https:amd64 <aucune> 1.2.24                                                             
2017-12-08 08:53:04 install python-pil:amd64 <aucune> 3.1.2-0ubuntu1.1                                                           
2017-12-08 08:53:04 install python-imaging:all <aucune> 3.1.2-0ubuntu1.1                                                         
2017-12-08 08:53:05 install python-numpy:amd64 <aucune> 1:1.11.0-1ubuntu1                                                         
2017-12-08 08:53:05 install minecraft-overviewer:amd64 <aucune> 0.12.204-0~overviewer1                                           
2017-12-08 09:32:31 install curl:amd64 <aucune> 7.47.0-1ubuntu2.5                                                                 
2017-12-08 09:41:03 install liberror-perl:all <aucune> 0.17-1.2                                                                   
2017-12-08 09:41:04 install git-man:all <aucune> 1:2.7.4-0ubuntu1.3                                                               
2017-12-08 09:41:04 install git:amd64 <aucune> 1:2.7.4-0ubuntu1.3                                                                 
2017-12-08 09:43:46 install linux-image-4.4.0-103-generic:amd64 <aucune> 4.4.0-103.126                                           
2017-12-08 09:43:49 install linux-image-extra-4.4.0-103-generic:amd64 <aucune> 4.4.0-103.126                                     
2017-12-08 09:43:55 install linux-headers-4.4.0-103:all <aucune> 4.4.0-103.126                                                   
2017-12-08 09:43:59 install linux-headers-4.4.0-103-generic:amd64 <aucune> 4.4.0-103.126                                         
2017-12-08 09:46:32 install librsync1:amd64 <aucune> 0.9.7-10                                                                     
2017-12-08 09:46:32 install make:amd64 <aucune> 4.1-6                                                                             
2017-12-08 09:46:32 install python-pylibacl:amd64 <aucune> 0.5.2-2build2                                                         
2017-12-08 09:46:33 install python-pyxattr:amd64 <aucune> 0.5.3-2build2                                                           
2017-12-08 09:46:33 install rdiff-backup:amd64 <aucune> 1.2.8-7                                                                   
2017-12-08 09:46:34 install socat:amd64 <aucune> 1.7.3.1-1                                                                       
2017-12-08 09:58:59 install libcommon-sense-perl:amd64 <aucune> 3.74-1build1                                                     
2017-12-08 09:58:59 install libjson-perl:all <aucune> 2.90-1                                                                     
2017-12-08 09:59:00 install libtypes-serialiser-perl:all <aucune> 1.0-1                                                           
2017-12-08 09:59:00 install libjson-xs-perl:amd64 <aucune> 3.010-2build1         

Le error.log et access.log d'apache2 n'affichent rien en revanche hmm

Blount, une idée?

Hors ligne

#2 2017-12-08 14:40:22

noz
Membre
Inscription : 2017-07-18
Messages : 6

Re : Cheky en erreur depuis màj système

Oups, mon log ne contient que les install, voici pour les upgrade:

2017-12-08 09:32:30 upgrade libcurl3-gnutls:amd64 7.47.0-1ubuntu2.4 7.47.0-1ubuntu2.5
2017-12-08 09:43:11 upgrade dpkg:amd64 1.18.4ubuntu1.2 1.18.4ubuntu1.3
2017-12-08 09:43:14 upgrade libpython3.5:amd64 3.5.2-2ubuntu0~16.04.3 3.5.2-2ubuntu0~16.04.4
2017-12-08 09:43:15 upgrade python3.5:amd64 3.5.2-2ubuntu0~16.04.3 3.5.2-2ubuntu0~16.04.4
2017-12-08 09:43:16 upgrade libpython3.5-stdlib:amd64 3.5.2-2ubuntu0~16.04.3 3.5.2-2ubuntu0~16.04.4
2017-12-08 09:43:17 upgrade python3.5-minimal:amd64 3.5.2-2ubuntu0~16.04.3 3.5.2-2ubuntu0~16.04.4
2017-12-08 09:43:18 upgrade libpython3.5-minimal:amd64 3.5.2-2ubuntu0~16.04.3 3.5.2-2ubuntu0~16.04.4
2017-12-08 09:43:18 upgrade db5.3-util:amd64 5.3.28-11 5.3.28-11ubuntu0.1
2017-12-08 09:43:19 upgrade libdb5.3:amd64 5.3.28-11 5.3.28-11ubuntu0.1
2017-12-08 09:43:21 upgrade python2.7-dev:amd64 2.7.12-1ubuntu0~16.04.1 2.7.12-1ubuntu0~16.04.2
2017-12-08 09:43:21 upgrade libpython2.7-dev:amd64 2.7.12-1ubuntu0~16.04.1 2.7.12-1ubuntu0~16.04.2
2017-12-08 09:43:24 upgrade libpython2.7:amd64 2.7.12-1ubuntu0~16.04.1 2.7.12-1ubuntu0~16.04.2
2017-12-08 09:43:24 upgrade python2.7:amd64 2.7.12-1ubuntu0~16.04.1 2.7.12-1ubuntu0~16.04.2
2017-12-08 09:43:25 upgrade libpython2.7-stdlib:amd64 2.7.12-1ubuntu0~16.04.1 2.7.12-1ubuntu0~16.04.2
2017-12-08 09:43:26 upgrade python2.7-minimal:amd64 2.7.12-1ubuntu0~16.04.1 2.7.12-1ubuntu0~16.04.2
2017-12-08 09:43:26 upgrade libpython2.7-minimal:amd64 2.7.12-1ubuntu0~16.04.1 2.7.12-1ubuntu0~16.04.2
2017-12-08 09:43:27 upgrade klibc-utils:amd64 2.0.4-8ubuntu1.16.04.3 2.0.4-8ubuntu1.16.04.4
2017-12-08 09:43:28 upgrade libklibc:amd64 2.0.4-8ubuntu1.16.04.3 2.0.4-8ubuntu1.16.04.4
2017-12-08 09:43:28 upgrade libisc-export160:amd64 1:9.10.3.dfsg.P4-8ubuntu1.8 1:9.10.3.dfsg.P4-8ubuntu1.9
2017-12-08 09:43:29 upgrade libdns-export162:amd64 1:9.10.3.dfsg.P4-8ubuntu1.8 1:9.10.3.dfsg.P4-8ubuntu1.9
2017-12-08 09:43:30 upgrade libxml2:amd64 2.9.3+dfsg1-1ubuntu0.3 2.9.3+dfsg1-1ubuntu0.4
2017-12-08 09:43:30 upgrade bind9:amd64 1:9.10.3.dfsg.P4-8ubuntu1.8 1:9.10.3.dfsg.P4-8ubuntu1.9
2017-12-08 09:43:31 upgrade dnsutils:amd64 1:9.10.3.dfsg.P4-8ubuntu1.8 1:9.10.3.dfsg.P4-8ubuntu1.9
2017-12-08 09:43:32 upgrade bind9-host:amd64 1:9.10.3.dfsg.P4-8ubuntu1.8 1:9.10.3.dfsg.P4-8ubuntu1.9
2017-12-08 09:43:33 upgrade libisc160:amd64 1:9.10.3.dfsg.P4-8ubuntu1.8 1:9.10.3.dfsg.P4-8ubuntu1.9
2017-12-08 09:43:35 upgrade libisccc140:amd64 1:9.10.3.dfsg.P4-8ubuntu1.8 1:9.10.3.dfsg.P4-8ubuntu1.9
2017-12-08 09:43:35 upgrade libisccfg140:amd64 1:9.10.3.dfsg.P4-8ubuntu1.8 1:9.10.3.dfsg.P4-8ubuntu1.9
2017-12-08 09:43:36 upgrade liblwres141:amd64 1:9.10.3.dfsg.P4-8ubuntu1.8 1:9.10.3.dfsg.P4-8ubuntu1.9
2017-12-08 09:43:36 upgrade libdns162:amd64 1:9.10.3.dfsg.P4-8ubuntu1.8 1:9.10.3.dfsg.P4-8ubuntu1.9
2017-12-08 09:43:37 upgrade libirs141:amd64 1:9.10.3.dfsg.P4-8ubuntu1.8 1:9.10.3.dfsg.P4-8ubuntu1.9
2017-12-08 09:43:38 upgrade bind9utils:amd64 1:9.10.3.dfsg.P4-8ubuntu1.8 1:9.10.3.dfsg.P4-8ubuntu1.9
2017-12-08 09:43:38 upgrade libbind9-140:amd64 1:9.10.3.dfsg.P4-8ubuntu1.8 1:9.10.3.dfsg.P4-8ubuntu1.9
2017-12-08 09:43:39 upgrade rsync:amd64 3.1.1-3ubuntu1 3.1.1-3ubuntu1.1
2017-12-08 09:43:40 upgrade libcurl3:amd64 7.47.0-1ubuntu2.4 7.47.0-1ubuntu2.5
2017-12-08 09:43:40 upgrade libpq5:amd64 9.5.9-0ubuntu0.16.04 9.5.10-0ubuntu0.16.04
2017-12-08 09:43:41 upgrade linux-firmware:all 1.157.13 1.157.14
2017-12-08 09:43:54 upgrade linux-generic:amd64 4.4.0.98.103 4.4.0.103.108
2017-12-08 09:43:55 upgrade linux-image-generic:amd64 4.4.0.98.103 4.4.0.103.108
2017-12-08 09:44:01 upgrade linux-headers-generic:amd64 4.4.0.98.103 4.4.0.103.108
2017-12-08 09:44:01 upgrade linux-libc-dev:amd64 4.4.0-98.121 4.4.0-103.126
2017-12-08 09:44:03 upgrade mdadm:amd64 3.3-2ubuntu7.5 3.3-2ubuntu7.6
2017-12-08 09:44:05 upgrade owncloud-files:all 10.0.3-1.1 10.0.4-1.1


Ca serait pas libcurl 7.47 qui poserait problème?

Hors ligne

#3 2017-12-08 16:23:39

Blount
Administrator
Inscription : 2010-11-16
Messages : 596

Re : Cheky en erreur depuis màj système

Tu peux regarder dans le fichier log de Cheky ? Dans cheky/var/log/error.log


Piost - Solution d'hébergement pour Cheky avec installation automatique.
https://www.piost.net

Hors ligne

#4 2017-12-11 09:31:00

noz
Membre
Inscription : 2017-07-18
Messages : 6

Re : Cheky en erreur depuis màj système

Bonjour Blount,

Effectivement, c'est bien Curl qui coince:

2017-12-10T20:54:15+01:00 ERROR Error : #0 Call to undefined function curl_init() (/home/noz/www/cheky/lib/Http/Client/Curl.php:11)                                                                                                                               
Même chose dans le info.log.

Infos système:
Ubuntu 16.04.3 LTS
noyau 3.14.32-xxxx-grs-ipv6-64

Merci smile

Hors ligne

#5 2017-12-11 10:26:27

Blount
Administrator
Inscription : 2010-11-16
Messages : 596

Re : Cheky en erreur depuis màj système

Tu as résolu le problème du coup ?
Il faut installer php curl.


Piost - Solution d'hébergement pour Cheky avec installation automatique.
https://www.piost.net

Hors ligne

#6 2017-12-11 11:26:25

noz
Membre
Inscription : 2017-07-18
Messages : 6

Re : Cheky en erreur depuis màj système

Effectivement, c'est résolu via un sudo apt install php-curl, puis redémarrage d'apache2.
Je ne comprends pas qu'il ait sauté, ça fonctionnait bien avant la mise à jour du système...
Mais au moins, problème résolu, merci beaucoup smile

Hors ligne

Pied de page des forums