Vous n'êtes pas identifié(e).

#1 2017-08-04 23:00:16

24images
Membre
Inscription : 2016-01-29
Messages : 12

version 3.5, test mail ne fonctionne pas, probleme de certif SSL

Impossible de mettre ma version 3.2 à jour via l'interface lui-même
Installation manuelle de la version 3.5 dans un nouveau dossier de mon hebergement (OVH)
Configuration d'une nouvelle tâche cron et désactivation de l'ancienne.
Régenération du certificat SSL de mon site
Configuration de la boite mail d'envoi : le test me renvoi un page d'erreur HTTP ERROR 500
Après une bonne heure verification du log :

2017-08-04T22:41:02+02:00 INFO [Pid 25678] Vérification des alertes.
2017-08-04T22:41:02+02:00 ERROR Exception : #0 Connexion vers https://www.leboncoin.fr échouée (erreur: SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed). (/home/philimaghw/www/LBCAlerte-3.5/app/notifier/scripts/check.php:513)

Après ouverture d'un ticket incident auprès d'OVH, il m'est confirmé que la tâche cron s'est correctement effectuée et que mon certificat SSl est correct.

Que faire ????

Hors ligne

#2 2017-08-05 10:01:02

Blount
Administrator
Inscription : 2010-11-16
Messages : 570

Re : version 3.5, test mail ne fonctionne pas, probleme de certif SSL

Bonjour,

Je n'ai pas vraiment d'idée.
Quelle version de PHP utilises-tu ?


Piost - Solution d'hébergement pour Cheky avec installation automatique.
https://www.piost.net

Hors ligne

#3 2017-08-05 15:19:18

24images
Membre
Inscription : 2016-01-29
Messages : 12

Re : version 3.5, test mail ne fonctionne pas, probleme de certif SSL

Bonjour,
J'utilise PHP 5.6

Je viens de faire un essai sur un autre site que je gère chez OVH, même topo exactement.

A quoi correspond ceci : home/philimaghw/www/LBCAlerte-3.5/app/notifier/scripts/check.php:513

Cela cite juste la ligne de notification  ?

Hors ligne

#4 2017-08-06 00:16:49

Dartagnan
Membre
Inscription : 2017-08-06
Messages : 3

Re : version 3.5, test mail ne fonctionne pas, probleme de certif SSL

j'ai le meme probleme
herbergement mutalise chez OVH
Certificat ok test mail ok

Hors ligne

#5 2017-08-06 00:49:13

Dartagnan
Membre
Inscription : 2017-08-06
Messages : 3

Re : version 3.5, test mail ne fonctionne pas, probleme de certif SSL

je me demande si ca serai pas leboncoin qui filtrerai pas les IP ovh

Hors ligne

#6 2017-08-07 09:40:26

dd_aw
Membre
Inscription : 2017-08-07
Messages : 3

Re : version 3.5, test mail ne fonctionne pas, probleme de certif SSL

Bonjour,

J'ai eu également le même souci.
Résolu avec la méthode de ce post de Phipila : https://forum.cheky.net/passage-version … 85-p1.html

Denis

Hors ligne

#7 2017-08-07 10:23:42

Dartagnan
Membre
Inscription : 2017-08-06
Messages : 3

Re : version 3.5, test mail ne fonctionne pas, probleme de certif SSL

Salut
Merci ca fonctionne parfaitement!!

Hors ligne

#8 2017-08-07 10:55:34

dd_aw
Membre
Inscription : 2017-08-07
Messages : 3

Re : version 3.5, test mail ne fonctionne pas, probleme de certif SSL

@Blount
Serait-il envisageable d'inclure cette ligne dans les prochaines versions ? Je m'aperçois que c'est un phénomène récurrent depuis pas mal de temps ...

Hors ligne

#9 2017-08-07 15:25:56

lpivtt
Membre
Inscription : 2017-08-07
Messages : 1

Re : version 3.5, test mail ne fonctionne pas, probleme de certif SSL

Bonjour,

Depuis le 02/08, plus d'alerte :-(
Je précise que je n'ai pas fait de montée de version (je suis en 3.3)  ni rien changé à mes tâches cron. Bizarre, bizarre que ça se soit mis à ne plus fonctionner d'un coup ?!

Symptôme : plus de mail d'alerte
Lancement de la tâche à la main = message "Une erreur s'est produite lors de l'exécution de xxxx/xxxxxx.php"
Consultation du fichier de logs xxxxxxxx/lbc/LBCAlerte-3.3/var/log/error.log ==> chaque tâche cron exécutée envoie un message d'erreur du type "2017-08-01T14:08:03+02:00 ERROR Exception : #0 Connexion vers https://www.leboncoin.fr échouée (erreur: SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed). (/home/enformeg/www/lbc/LBCAlerte-3.3/app/mail/scripts/check.php:468)
2017-08-01T14:17:02+02:00 ERROR Exception : #0 Connexion vers https://www.leboncoin.fr échouée (erreur: SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed)"

Bref big :-(((((

J'ai donc fait quelques recherches et suis tombé sur ce fil, grâce auquel j'ai appliqué le tuyau fourni par dd_aw ! Ajout de la ligne de code tel que décrit dans le fil fourni en lien, et hop tout refonctionne !

Merci pour l'entraide, c'est super appréciable !

Hors ligne

#10 2017-08-07 22:52:37

24images
Membre
Inscription : 2016-01-29
Messages : 12

Re : version 3.5, test mail ne fonctionne pas, probleme de certif SSL

Ben ça alors depuis ce soir
la version 3.5 fonctionne normalement à nouveau
Y aurait il eu une manip de faite chez OVH ????
Un coup d'oeil au log : tout y est normal

Hors ligne

#11 2017-08-07 23:36:59

Blount
Administrator
Inscription : 2010-11-16
Messages : 570

Re : version 3.5, test mail ne fonctionne pas, probleme de certif SSL

Je ne pense pas que d'ignorer la vérification des certificats soit la bonne solution, même si cela fonctionne.
Pour moi, les certificats de Leboncoin sont bons (à jour et chez Gandi), le problème vient donc de l'hébergement. Sur mon serveur, je n'ai jamais eu de problème à ce niveau.
OVH peuvent bien dire qu'il n'y a pas de souci, mais dire "la tâche cron s'est bien exécutée" c'est facile. La tâche est bien exécutée parce que les erreurs sont gérées correctement et enregistrées dans un fichier log.
Tu leur as fourni les lignes du fichier log ?


Piost - Solution d'hébergement pour Cheky avec installation automatique.
https://www.piost.net

Hors ligne

#12 2017-08-08 09:29:56

dd_aw
Membre
Inscription : 2017-08-07
Messages : 3

Re : version 3.5, test mail ne fonctionne pas, probleme de certif SSL

Comme 24images hier,  ce matin j'ai retiré le patch "curl_setopt($this->_resource, CURLOPT_SSL_VERIFYPEER, false);", >>cela fonctionne maintenant sans celui ceci...

J'aimerais quand même bien en connaître la raison.

Hors ligne

Pied de page des forums