Vous n'êtes pas identifié(e).

#1 2015-06-21 13:23:42

Arthas
Membre
Inscription : 2013-05-09
Messages : 3

Mise à jour depuis 2.5 vers 2.61 ne fonctionne pas : PHP Fatal error

Bonjour,

Depuis LBCAlerte 2.5, lorsque je tente de mettre à jour depuis la partie administration, j'ai une page blanche qui s'affiche dans le navigateur et rien ne se passe.
J'ai tenté un reboot du serveur mais pas mieux.


Dans les logs PHP, j'ai ceci :

2015/06/21 12:20:31 [error] 222#0: *6399 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Class 'App\ZipArchive' not found in /srv/http/LBCAlerte-2.5/app/models/Updater.php on line 124" while reading response header from upstream, client: 192.168.1.1, server: MonServeurX, request: "POST /?mod=admin&a=upgrade HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm/php-fpm.sock:", host: "MonServeurX", referrer: "http://MonServeurX/?mod=admin&a=upgrade"

Pour reproduire
- LBCAlerte en v2.5
- Se connecter en admin
- Cliquer sur "Administration" => Onglet "Mise à jour" => Bouton "mettre à jour"
- une page blanche s'affiche avec dans la barre d'adresse : http://MonServeurX/?mod=admin&a=upgrade

je sais pas si c'est lié au bug lors de l'installation ? http://alerte.ilatumi.org/forum/viewtop … &p=2#p1222

En éditant le fichier Updater.php avec vim, il ya des caractères étranges "^M"

<?php

namespace App;^M
^M
class Updater^M
{
...

J'ai fais un dos2unix pour les enlever mais ça n'a rien changé.


Infos sur le serveur

# php -version

PHP 5.6.10 (cli) (built: Jun 11 2015 19:35:08) 
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies

Le module est bien activé dans le php.ini :

;extension=bcmath.so
;extension=bz2.so
;extension=calendar.so
extension=curl.so
;extension=dba.so
;extension=enchant.so
;extension=exif.so
;extension=ftp.so
extension=gd.so
extension=gettext.so
;extension=gmp.so
extension=iconv.so
;extension=imap.so
;extension=intl.so
;extension=ldap.so
;extension=mcrypt.so
;extension=mssql.so
;extension=mysql.so
;extension=mysqli.so
;extension=odbc.so
;zend_extension=opcache.so
extension=openssl.so
;extension=pdo_mysql.so
;extension=pdo_odbc.so
;extension=pdo_pgsql.so
extension=pdo_sqlite.so
;extension=pgsql.so
extension=phar.so
;extension=posix.so
;extension=pspell.so
;extension=shmop.so
;extension=snmp.so
;extension=soap.so
;extension=sockets.so
extension=sqlite3.so
;extension=sysvmsg.so
;extension=sysvsem.so
;extension=sysvshm.so
extension=tidy.so
extension=xmlrpc.so
;extension=xsl.so
extension=zip.so

Confirmé par :
# php -i

zip

Zip => enabled
Extension Version => $Id: f9f12af1274212b9f22867472e4aa57eab4bb4cf $
Zip version => 1.12.5
Libzip version => 1.0.1

Des idées sur cette erreur ?
A moins que ça ne soit lié à la 2.6.1 ?

Hors ligne

Pied de page des forums